Vulnerabilities-Web Application Security

CVE-2015-0204 Freak Attack

It has been discovered that OpenSSL before 0.9.8zd, 1.0.0 before 1.0.0p, and 1.0.1 before 1.0.1k are vulnerable to a downgrade attack. In short, an attacker could man-in-the-middle a user and web server, force the user and server to downgrade to a set of export ciphers which are weak and outdated. They could then brute force the key and thus decrypt the HTTPS traffic between the user and the web application. Once the key has been decrypted the attacker can use the key for all HTTPS traffic from the server until a new key is produced.

The current solution is to disable support for any export suites. According to the best solution is to “disable support for any export suites. However, instead of simply excluding RSA export cipher suites, we encourage administrators to disable support for all known insecure ciphers (e.g., there are export cipher suites protocols beyond RSA) and enable forward secrecy. Mozilla has published a guide and SSL Configuration Generator, which will generate known good configurations for common servers. You can check whether your site using the SSL Labs’ SSL Server Test.”

WhiteHat Security already tests for weak cipher suites as part of our Premium Edition service. If you have any questions about this vulnerability please reach out to our Customer Support team at [email protected]